注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

沉默蜂B4A安卓编程

国内资料最全的B4A资料库

 
 
 

日志

 
 

编译失败之使用已过时的API  

2017-03-12 12:16:54|  分类: 调试发布 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
编译失败之使用过时的API - 沉默蜂 - 沉默蜂B4A安卓编程
在B4A 6.8汉化环境编译某个项目时出错
 
编译失败之使用过时的API - 沉默蜂 - 沉默蜂B4A安卓编程
在B4A 6.8汉化环境编译某个项目时出错

编译失败之使用过时的API - 沉默蜂 - 沉默蜂B4A安卓编程
后来一查,原来使用了较高版本 android-23

编译失败之使用过时的API - 沉默蜂 - 沉默蜂B4A安卓编程
换成较低版本 android-19就能顺利通过



当时我发现这个问题的时候,还以为是汉化版本造成的,后来用英文版本进行编译,也没有通过,仍报使用了过时的API,后来又换到汉化版,仍是这样的问题,于是就慢慢揣摩这“过时的API”,于是到配置对话框找找,,看看是否能有所灵感,尝试着把版本降下来点,终于成功了。 
 


 
  评论这张
 
阅读(16)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017